The term EtherChannel or PortChannel is a a method of aggregation that allows multiple physical Ethernet links to be combined or bundled at Layer 2 into one logical interface or channel. Bundling Ethernet interfaces at Layer 2 is vary similar to that of PPP or MLFR that we find with Serial interfaces.Traffic can be load balanced among the links in the channel as well as redundancy in the event that one or more links in the channel fail.

PAgP – Is Cisco proprietary link aggregation protocol
PAgP – The overall idea is to trick upper layer Spanning Tree protocol into thinking the link is one single path
PAgP – Negotiation Auto is simply listening for the frames not advertising them
PAgP – Negotiation Desirable is sending the frame out
PAgP – The hashing and configuration will take place with the logical interface such as po1, 2, 3 etc

  • On – – – – – – – – – – – On
  • Auto – – – – – – – – – – Desirable
  • Auto – – – – – X – – – – Auto
  • Desirable – – – – – – – Desirable

LACP – The IEEE 802.3ad open standard for EtherChannel negotiation
LACP – The overall idea is to trick upper layer Spanning Tree protocol into thinking the link is one single path
LACP – Negotiation Active is sending the frame out
LACP – Negotiation Passive is simply listening for the frames not advertising them
LACP – The hashing and configuration will take place with logical interface port such as po1, 2,3 etc

  • On – – – – – – – – – – – On
  • Active – – – – – – – – Active
  • Passive – – – X – – – Passive
  • Active – – – – – – – – Passive

The available load balancing options for PAgP and LACP range from Layer 2 to Layer 4. Basically you have the option of looking at the Layer 2, 3, and 4 Headers within the Ethernet frames as they traverse the channel when making load balancing decisions.

Available Load Balancing Options at Layers 2, 3, and 4

  • Layer 2 Source MAC Address
  • Layer 2 Destination MAC Address
  • Layer 2 Source and Destination MAC Address
  • Layer 3 Source IP Address  
  • Layer 3 Destination IP Address
  • Layer 3 Source and Destination IP Address
  • Layer 4 Source Port
  • Layer 4 Destination Port
  • Layer 4 Source and Destination Port

Lets configured a simple EtherChannel group between two switches SW1, and SW2 as depicted in the above diagram. Lets start off by configuring Spanning Tree Root bridge priority. Be defining were the placement of the Root Bridge is within the Layer 2 topology guarantees stable Layer 2 decisions. If the above were simply 4 individual Ethernet connection, and each switch was configured as a separate Root Bridge it would be possible, and highly likely that Lyer 2 frames would be traversing all for connection independently. 

SW1#configure terminal
SW1(config)#vtp mode Server
SW1(config)#vtp domain ABC
SW1(config)#spanning-tree priority vlan 2, 3, 4 4096
SW1(config)#exit
SW1#

Lets get the LACP System Priority configured on Switch SW1

SW1#configure terminal
SW1(config)#lacp system-priority 4096
SW1(config)#exit
SW1#

Switch SW1 will be configured with a negotiation type of active, while switch SW2 is configured with a negotiation type of passive. I could have used a negotiation mode of on which would have essentially disabled any and all auto negotiation and across the etherchannel.

SW1#configure terminal
SW1(config)#interface range Gigabitethernet1/0/1 - 3
SW1(config-if-range)#description Trunk to SW2
SW1(config-if-range)#channel-group 1 mode active
SW1(config-if-range)#exit
SW1(config)#

This is the piece of the configuration that’s most often overlooked or forgotten. Fortunately the Etherchannel will continue to function, but the Layer 2 frames traversing the link will not be balanced across the links and the performance will suffer. The load balancing method the you choose to use in your environment is clearly up you. Personally I prefer to use one of the Layer 2 methods.

SW1(config)#port-channel load-balance src-mac
SW1(config)#exit

Now that we have the Physical etherchannel interfaces built or grouped together on SW1 we can start to use the virtual port-channel 1 or po1 to refer to the bundle. So for example if we were to create another etherchannel on SW1 it would have a virtual interface called port-channel 2 or po2 etc.

SW1(config)#interface port-channel 1
SW1(config-if)#description Port Channel
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#exit
SW1(config)#

Now lets make sure that switch SW2 is configured as a VTP client, and not Server..!

SW2(config)#vtp mode client
SW2(config)#vtp domain ABC

As mentioned above switch SW2 will be configured with a negotiation type of passive. We could have used a negotiation mode of type on which would have essentially disabled any and all auto negotiation between switch SW1 and switch SW2.

SW2(config)#interface range Gigabitethernet1/0/1 - 3
SW2(config-if-range)#description Trunk to SW1
SW2(config-if-range)#channel-group 1 mode passive
SW2(config-if-range)#exit
SW2(config)#

It’s always good practice to define a Load Balancing method across the EhterChannel, so I’m going to configure the load balancing method on Switch SW2 so it matches the load balancing configuration on Switch SW1.

SW2(config)#port-channel load-balance src-mac

As mentioned above now that we have the physical etherchannel built on SW2 we can start refer to the virtual Port Channel Interface or po1 on SW2. As also mentioned above if we were to create another etherchannel on SW2 it would have a virtual interface called po3, po3, and po4 etc.

SW2(config)#interface port-channel 1
SW2(config-if)#description Port Channel
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport nonegotiate
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#end
SW2# 

I hope you found this post on PAgP & LACP helpful and informative. Be sure to let me know what you think by leaving suggestions, and feedback in the comments section below. You can find out more about these and other articles be checking out recent posts and archives. To learn more about me be sure to check out the About page. And as always thanks again for visiting The Packet.