VTP

VLAN Trunking Protocol or VTP reduces administration in a switched network. When you configure a new VLAN on one VTP Server the VLAN is distributed through all switches in the VTP domain. This reduces the need to configure the same VLAN everywhere. VTP is a Cisco-proprietary protocol that is available on most of the Cisco Catalyst series products. In short VTP stretches or extends the Layer 2 broadcast ( FFFF.FFFF.FFFF ) domain across Switches.


VTP Modes

  • Server
  • Client
  • Transparent

The normal range of VLANs range from 1 – 1001, and extended range of VLANs range from 1006 – 4094. The normal range of VLANs are stored in the the vlan.dat on the flash filesystem of the Switch. The normal range VLANs can be advertised via VTP over trunk ports. Extended range VLANs can not be advertised via VTP and are not stored in the vlan.dat database. The extended range of VLANs are stored in the running configuration only. The Switch must also be running in Transparent mode in order to configure the extended range of VLANs.


VLAN Ranges

  • VLAN 0 – Reserved
  • VLAN 1 – Default
  • VLAN 4095 – Reserved
  • VLAN range 1 –  1001 – Normal
  • VLAN range 1002 – 1005 Designed specifically for use with FDDI
  • VLAN range 1006 – 4094 Extended

The concept of EtherChannels doesn’t really have anything to do with VTP itself, but I wanted to talk about or show how an EtherChannel or logical bundle can be configured, and treated in much the same way as a  single Trunk port. This is also the time you want to make sure your Spanning Tree Protocols is configured correctly.

LACP vs. PAgP

Link Aggregation Control Protocol or LACP is part of an IEEE specification 802.3ad that allows you to bundle several physical ports together to form a single logical channel. LACP allows a switch to negotiate an automatic bundle by sending LACP packets to the peer. It performs a similar function as Port Aggregation Protocol or PAgP with Cisco EtherChannel.

Port aggregation protocol or PAgP aids in the automatic creation of Fast EtherChannel links. PAgP packets are sent between Fast EtherChannel capable ports in order to negotiate the forming of a channel. You can see my post on PAgP and LCAP for further information on these Layer 2 Protocols.

Configure Switch SW1’s interface gi1/0/19 trunking and EtherChannel

SW1#configure terminal
SW1(config)#interface GigabitEthernet1/0/19
SW1(config-if)#description Trunk to SW2
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#end
SW1#

Configure Switch SW1’s interface gi1/0/20 for trunking and EtherChannel

SW1#configure terminal
SW1(config)#interface GigabitEthernet1/0/20
SW1(config-if)#description Trunk to SW3
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#end
SW1#

Configure Switch SW1’s interface gi1/0/21 for trunking and EtherChannel

SW1#configure terminal
SW1(config)#interface GigabitEthernet1/0/21
SW1(config-if)#description Trunk to SW3
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#end
SW1#

Configure Switch SW1’s interface gi1/0/22 trunking and EtherChannel

SW1#configure terminal
SW1(config)#interface GigabitEthernet1/0/22
SW1(config-if)#description Trunk to SW3
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#end
SW1#

Configure Switch SW1’s interface gi1/0/23 for Trunking and EtherChannel

SW1#configure terminal
SW1(config)#interface GigabitEthernet1/0/23
SW1(config-if)#description Trunk to SW3
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#end
SW1#

Configure SW1’s interface PO1 for Trunking

SW1#configure terminal
SW1(config)#interface Port-channel1
SW1(config)#description EChannel to SW3
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate
SW1(config-if)#end
SW1#

Lets take a look at the status of the EtherChannel from SW1 point of view

SW1#show EtherChannel summary

Flags: D - down P - in port-channelI
I- stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer 2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/0/20(P) Gi1/0/21(P) Gi2/0/22(P) Gi2/0/23(P)
SW2#show run interface gi1/0/24

interface GigabitEthernet1/24
description Trunk to SW1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
SW3#show run interface gi1/0/21

interface GigabitEthernet1/21
description Trunk to SW1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
SW3#show run interface gi1/0/22

interface GigabitEthernet1/0/22
description Trunk to SW1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
SW3#show run interface gi1/0/23

interface GigabitEthernet1/0/23
description Trunk to SW1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
SW3#show run interface po1

interface Port-channel1
description eChannel to SW1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

Lets take a look at the status of the EtherChannel from SW3 point of view

SW3#show etherchannel summary

Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/0/20(P) Gi1/0/21(P) Gi2/0/22(P) Gi2/0/23(P)

Routing Switching Voice Firewall Wireless